Re: Mono-list Digest, Vol 145, Issue 2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mono-list Digest, Vol 145, Issue 2

Wolfgang Mauer-2
Have you tried "MONO_LOG_LEVEL=debug mono --debug --debugger-agent="address=0.0.0.0:10000,transport=dt_socket,server=y" ....."
Maybe "MONO_LOG_LEVEL=debug" gives you more information what's happen...

 
Von: nikhil sehgal <[hidden email]>
Gesendet: 17.06.2017 14:02
An: <[hidden email]>,<[hidden email]>
Betreff: Re: [Mono-list] Mono-list Digest, Vol 145, Issue 2
 
Anyone please help
 
On Jun 7, 2017 9:13 PM, "nikhil sehgal" <[hidden email]> wrote:
Hi we have tried soft debugger as suggested still facing some challenges as explained below.
 
I tried following steps.
 
1.   Download and install Xamarin StudioGTK# for .NET and .NET Framework 4.6.2. Xamarin Studio requires .NET 4.5 but GTK# requires .NET 4.6. I used Xamarin Studio version 6.1.2 (build 44) and GTK# version 2.12.44.
 
2.   I installed Xamarin Studio on a virtual machine different from my VS2015 machine, so I needed to download and install MSBuild Tools 2013 and MSBuild Tools 2015 as well.
 
3.   Create an environment variable MONODEVELOP_SDB_TEST = 1 (My Computer -> Properties -> Advanced System Settings -> Environment Variables).
 
4.   I created a .NET 4.6 Console Application in Visual Studio 2015.
 
5.   Load the .sln or .csproj file from Visual Studio into Xamarin Studio. Build the solution and use the pdb2mdb tool from the NuGet packages folder to create a .mdbfile: pdb2mdb MyProgram.exe
 
6.   On linux machin,Start the Mono runtime with debugger flags: mono --debug --debugger-agent=transport=dt_socket,address=0.0.0.0:12345,server=y /path/to/MyProgram.exe. This will start the program but halt execution until the Xamarin Studio debugger has connected.
 
7.   Set a breakpoint in Xamarin Studio and select the menu item Run -> Run with -> Custom Configuration... and select Run Action = Debug - Custom Command Mono Soft Debugger. Click Debug.
 
8.   Fill in the IP and Port fields with the IP address of your linux system and port 12345 as specified in the Mono command line. Click Connect and execution will begin, stopping at the breakpoint set.
 
I am able to debug console application/any exe. But while I am trying to debug web services running on Nginx for that in above mentioned steps 6. I have tried following .
a.   mono --debug --debugger-agent=transport=dt_socket,address=0.0.0.0:12345,server=y /[complete Url of the web services]
 
This start the program but halt execution until but I am not be able to connect to above mentioned halted URI.
 
 
Question: How can I debug the mono Web Services running on Linux machine, Where Web services is hosted on Nginx Server using soft-monodebug 
Regards
Nikhil
 
On May 2, 2017 11:24 AM, <[hidden email]> wrote:
Send Mono-list mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.dot.net/mailman/listinfo/mono-list
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Mono-list digest..."


Today's Topics:

   1. Re: Configuring xbuild on Jenkins server hosted on        windows or
      Linux (nikhil sehgal)
   2. Re: Remotely step by step debugging we services hosted on
      nginx & fastcgi on ubuntu (nikhil sehgal)
   3. Re: Remotely step by step debugging we services hosted on
      nginx & fastcgi on ubuntu (Jonathan Mitchell)
   4. ❤some articles (init0)


----------------------------------------------------------------------

Message: 1
Date: Mon, 1 May 2017 17:38:49 +0530
From: nikhil sehgal <[hidden email]>
To: [hidden email], [hidden email]
Subject: Re: [Mono-list] Configuring xbuild on Jenkins server hosted
        on      windows or Linux
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset="utf-8"

Any more thoughts?

On Apr 30, 2017 12:27 PM, "nikhil sehgal" <[hidden email]> wrote:

> Hi all,
>
> I would like to configure my Jenkins build server to build my code using
> xbuild so if my code have something incompatible with mono it should break.
>
> My question is do I need to configure my Jenkins server on Linux only so
> it use xbuild for Linux to build my code .?
>
> Or
>
> If my Jenkins server is configured on windows and using xbuild for windows
> it's same as on Linux?
>
> Regards
> Nikhil
> --
> Thanks & Regards
> NIkhil Sehgal
> Mobile No 9711855929
> Email Id [hidden email]
> Skype ID sehgal.nikhil
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170501/f6e5f592/attachment-0001.html>

------------------------------

Message: 2
Date: Mon, 1 May 2017 17:39:04 +0530
From: nikhil sehgal <[hidden email]>
To: [hidden email],  "[hidden email]"
        <[hidden email]>,  "[hidden email]"
        <[hidden email]>
Subject: Re: [Mono-list] Remotely step by step debugging we services
        hosted on nginx & fastcgi on ubuntu
Message-ID:
        <CAF0vV7z+G_92RbQ4p4STGe9d6-uLy1D=[hidden email]>
Content-Type: text/plain; charset="utf-8"

Any thoughts ?

On Apr 30, 2017 12:17 PM, "nikhil sehgal" <[hidden email]> wrote:

> Hi all
>
> Hope you are doing great!
>
> I have my web-service hosted on nginx webserver on ubuntu using fastcgi
> for mono.
>
> I want to debug it remotely by attaching it to some process so my symbols
> are loaded and I can do step by step debugging.
>
> Please advice
>
> Regards
> Nikhi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170501/38e9b540/attachment-0001.html>

------------------------------

Message: 3
Date: Mon, 1 May 2017 20:36:27 +0100
From: Jonathan Mitchell <[hidden email]>
To: [hidden email]
Subject: Re: [Mono-list] Remotely step by step debugging we services
        hosted on nginx & fastcgi on ubuntu
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="utf-8"

The Soft Debugger is likely what you are looking for.

http://www.mono-project.com/docs/debug+profile/debug/debugger/ <http://www.mono-project.com/docs/debug+profile/debug/debugger/>

http://www.mono-project.com/docs/advanced/runtime/docs/soft-debugger/ <http://www.mono-project.com/docs/advanced/runtime/docs/soft-debugger/>

https://eladnava.com/debug-remote-mono-apps-via-xamarin-studio/ <https://eladnava.com/debug-remote-mono-apps-via-xamarin-studio/>

J

> On 1 May 2017, at 13:09, nikhil sehgal <[hidden email]> wrote:
>
> Any thoughts ?
>
> On Apr 30, 2017 12:17 PM, "nikhil sehgal" <[hidden email] <mailto:[hidden email]>> wrote:
> Hi all
>
> Hope you are doing great!
>
> I have my web-service hosted on nginx webserver on ubuntu using fastcgi for mono.
>
> I want to debug it remotely by attaching it to some process so my symbols are loaded and I can do step by step debugging.
>
> Please advice
>
> Regards
> Nikhil
>
> --
> Thanks & Regards
> NIkhil Sehgal
> Mobile No 9711855929
> Email Id [hidden email] <mailto:[hidden email]>
> Skype ID sehgal.nikhil
> _______________________________________________
> Mono-list maillist  -  [hidden email] <mailto:[hidden email]>
> http://lists.dot.net/mailman/listinfo/mono-list <http://lists.dot.net/mailman/listinfo/mono-list>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170501/72f75564/attachment-0001.html>

------------------------------

Message: 4
Date: Tue, 2 May 2017 02:53:41 -0300
From: "init0" <[hidden email]>
To: "mono-list" <[hidden email]>
Subject: [Mono-list] ❤some articles
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="utf-8"

Greetings,

Here are some really helpful articles, I think you may like  them.Please read them here http://justice.thathairything.com

init0



From: mono-list [mailto:[hidden email]]
Sent: Tuesday, May 02, 2017 1:53 AM
To: [hidden email]
Subject: Congrats Dude!

Mobile, so can't reference your post as i write.

Carrying with one  in that chamber is common and preferred. Having  to rack a  weapon before use can lose tactical advantage.

I don't know what  weapon she had, so can't  comment on  specifics.  That said, not every weapon is a good carry  weapon. Further more, weapons should be picked to match specific needs and  skill set.

Many carry weapons do not have active safeties. Meaning, no switch to  switch. This is  to ensure the weapon can be used  in high stress  situations without  worry of forgetting or fumbling to turn off. Many  (most/all) carry weapons  do  have  multiple passive safeties which prevent the weapon  from discharging  when dropped and or require  a finger to physically be on the trigger. Meaning it can only be  fired  intentionally.


In general, women  carrying  in their purse is  heavily frowned upon. Honestly, in  my  opinion, its stupid. Its a sign  they perhaps should  not be carrying in the  first place. A weapon  in the  purse  encourages the women to lose  control of her weapon in even the best of circumstances. Its reckless and  dangerous.  As  is  exactly what happened here. Her decision to  carry in her purse killed her. It was a bad decision. Secondly, carrying in a  purse encourages  the  weapon to be stolen, thereby  leaving the women  entirely unarmed, and  worse,  her assailant is now  armed. At best she  has fed the gun  black market. Women should never carry in their purse,  save  only  in very uncommon situations.

That said, many state laws  basically force women  to decide between  their ability to protect  themselves and going out. As some  laws  frequently force  these poor decisions under the guise its a bad idea but better  than nothing. That's why  in part open carry is  constitutionally protected and illegal in all states that prevent it. People  should never  be forced to surrender their right to self protection unless  it steps on someone else's constitutional rights.

While  this is most definitely a sad situation, the real  problem is  that many  thousands of guns are used annually to protect  people and  save lives yet this accident is held high by  trashy media  and unintelligent  leftists. If the left actually cared,  they would  be campaigning for women to not carry  in their purse and to once again encourage gun education in our schools.


Sent from Mail for Windows 10
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170502/b5a3097d/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 03F431012603283AD1002AE2CCFDCE03.jpg
Type: image/jpeg
Size: 15559 bytes
Desc: not available
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170502/b5a3097d/attachment.jpg>

------------------------------

Subject: Digest Footer

_______________________________________________
Mono-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-list


------------------------------

End of Mono-list Digest, Vol 145, Issue 2
*****************************************

_______________________________________________
Mono-list maillist  -  [hidden email]
http://lists.dot.net/mailman/listinfo/mono-list
Loading...