Quantcast

Unrecognized attribute 'targetFramework'

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unrecognized attribute 'targetFramework'

Alexander M. Batishchev

Hi everybody,

 

When I’m trying to open my ASP.NET web application created in VS2010 and targeted to Framework 4.0, I’m getting next error:

 

    Unrecognized attribute 'targetFramework'. (/home/godfather/Projects/MiniOperDay/MiniOperDay.WebApp/Web.config line 1)

    …

    Version information: Mono Runtime Version: 2.7 (/trunk/mono r158785 Sat Jun 12 12:51:49 MSD 2010); ASP.NET Version: 2.0.50727.1433

 

Is it a bug and I should file it or there is some way to switch XSP to runtime ver. 4.0?

 

$ xsp --version

xsp2.exe 2.7.0.0

 

Thanks in advance.

Alex


_______________________________________________
Mono-aspnet-list mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/mono-aspnet-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unrecognized attribute 'targetFramework'

Robert Jordan
On 12.06.2010 11:37, Alexander M. Batishchev wrote:
> Is it a bug and I should file it or there is some way to switch XSP to
> runtime ver. 4.0?
>
>
>
> $ xsp --version
>
> xsp2.exe 2.7.0.0
>

The version of xsp targeting .NET 4.0 is called "xsp4".

Robert

_______________________________________________
Mono-aspnet-list mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/mono-aspnet-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unrecognized attribute 'targetFramework'

Alexander M. Batishchev
Thanks a lot!

But both attributes controlRenderingCompatibilityVersion="3.5" and
clientIDMode="AutoID" under system.web/pages node are not recognized.
Error 500: Server Error in '/' Application

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Robert
Jordan
Sent: Saturday, June 12, 2010 4:40 PM
To: [hidden email]
Subject: Re: [Mono-aspnet-list] Unrecognized attribute 'targetFramework'

On 12.06.2010 11:37, Alexander M. Batishchev wrote:
> Is it a bug and I should file it or there is some way to switch XSP to
> runtime ver. 4.0?
>
>
>
> $ xsp --version
>
> xsp2.exe 2.7.0.0
>

The version of xsp targeting .NET 4.0 is called "xsp4".

Robert

_______________________________________________
Mono-aspnet-list mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/mono-aspnet-list

_______________________________________________
Mono-aspnet-list mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/mono-aspnet-list
Loading...